How to fit your RGS Performance Oil Sensor Adapter

Fitting an aftermarket oil pressure or gauge is one of the first things many enthusiasts do to overcome the often unreliable factory sensors. There are many ways to go about this, but adding the sensor in the factory location is the best way to ensure accurate pressure readings. The sensor adapter I sell HERE allows you to do this quickly and easily, and has the correct threads for both your factory sensor, which uses British Standard Pipe Thread, and an aftermarket sensor using National Pipe Thread.

I Recently fit one of these to a customer's car, so I took the opportunity to take some photos along the way and put together a little how to.

Before You Start: The fittings that we are working with all seal on a tapered thread, not a seat or a flare or a washer like some other fluid seals throughout the car. The fittings need to be done up tight, but not overly tight or else you risk damaging the component. A good quality thread sealer left to cure overnight should guarantee an OEM quality seal that will last for years to come.

What You Will Need: The tools I used for the job include a 17mm stubby spanner, an 18mm stubby spanner, an 11/16 socket, my sensors and adapter, and of course a well used tube of Loctite 567 Master Pipe Thread Sealant.

Left to right Loctite 567. Sensor Adapter, 11/16" socket, Factory OPS, 17mm stubby spanner, Aftermarket OPS, 18mm stubby spanner.

How to Install

Locate your OEM Oil Pressure Sensor (OPS). On a Japanese or Australian vehicle this is on the passenger side and is attached to the engine mount bracket. Disconnect the harness plug from the sender.

The factory Oil Pressure Sensor (OPS) installed in the original location.

Use the 17mm stubby spanner on the nut on the top of the sender to remove the sender from the junction. There is just enough room to swing the spanner around. Have a rag handy to catch any dribbles of oil.

It's very tight in there and the 17mm hex that is used to remove and refit the Sensor is right on the top of the unit.

The pic below shows how everything will fit together when installed with the aftermarket sender on the T and the OEM sender on the run. Start by installing the adapter into the junction on the motor. The body of the sender is machined to fit an 11/16" socket or spanner - as I only had a half inch drive socket in that side I had to make do with that and use a fairly light touch. Make sure you apply some thread sealant to the male threads on the sender. I installed the adapter with the port for the aftermarket sensor facing towards the front of the motor.

The sensors and adapters as they will sit once installed in the motor. The factory sensor screws into the bottom of the adapter, the aftermarket sensor screws into the side. It is important to maintain this orientation as each sensor has different threads.

With the adapter in place you can now install your aftermarket sender into the T. Again make sure you use some thread sealant on the sender. This Calibra sender (which is fairly generic) has an 18mm hex machined onto it, and I found that I had plenty of space to tighten it up with a stubby.

The adapter installed into the original junction, and the aftermarket sensor installed into the adapter. The sensor is facing towards the front of the car.

Install the OEM sensor into the run on the adapter, using thread sealant and tightening with a 17mm spanner. If you have an 11/16 spanner or go through socket it would be advisable to hold the body of the adpater as you tighten. The new position of the OEM sensor is very close to the steering rack, so I removed the boot from the harness connector to make reassembly that little bit easier. The last step is to cable tie the harness in place.

Everything installed and the wiring harness cable tied away from any moving parts.

No Comments Yet.

Leave a comment